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PageDraw is a vector-based drawing program. It has powerful tools for drawing, editing and 
transforming graphical objects. After you have drawn a few objects, you can select an object, or a group 
of objects, and transform them. Objects remain editable even after transformation. To edit an object, 
select the object, and drag any of the objects handles.

The following two sections describe the tools available on the tool bar. To select a tool, click on the 
button representing the tool on the tool bar. Operations started using any tool can be canceled at any 
time by selecting another tool from the tool bar. Note that the shift key can be used to modify the 
operation of most tools.

How to draw
Line
Horizontal line
Vertical line
Rectangle
Square
Ellipse
Circle
Arc
Curve
Polygon
Text

After you have drawn an object, you can transform the object in a number of ways. You can transform an
object independently or you can select a group of objects to be transformed together. PageDraw treats 
text and graphics uniformly during transformation.

How to transform objects
Move
Scale
Rotate
Skew
Reflect

How to...
Include your drawing in a word processor document
Change orientation to portrait or landscape mode
Change line thickness or dash style
Change fill shade or pattern
Draw arrow heads at line ends

Miscellaneous
Send me your comments, bug reports, and request for new features
PageDraw is FREE software
NO WARRANTY



How to draw a line

Select the line tool from the tool bar. Click the left mouse button where you want the line to start. Without
releasing the button, drag the mouse to the point where you want the line to end.

To constrain the line to a vertical or horizontal line, hold down the shift key while dragging the mouse.



How to draw a polygon

Select the polygon tool from the tool bar. Click the left mouse button where you want the first vertex of 
the polygon. Without releasing the button, drag the mouse to the point where you want the second 
vertex, then release the button. Click the left mouse button where you want the next vertex and release 
the button. Click and release the left mouse button where you want the next vertex, and the next, and so
on. When you come to the last vertex, double click the left mouse button.

To draw a closed polygon, double click on the first vertex, as the last vertex.



How to draw a rectangle

Select the rectangle tool from the tool bar. Click the left mouse button where you want the first corner of 
the rectangle. Without releasing the button, drag the mouse to the point where you want the opposite 
corner of the rectangle.

To constrain the rectangle to a square, hold down the shift key while dragging the mouse.



How to draw an ellipse

Select the ellipse tool from the tool bar. Click the left mouse button where you want the center of the 
ellipse. Without releasing the button, drag the mouse till the ellipse has the desired size and shape.

To constrain the ellipse to a circle, hold down the shift key while dragging the mouse.



How to draw an arc

Select the arc tool from the tool bar. Click the left mouse button where you want the center of the arc. 
Click the left mouse button where you want the arcs starting angle. Without releasing the button, drag 
the mouse anticlockwise to the ending angle, while also moving away from the center till the arc has the 
desired radius.



How to draw a pie slice

Select the pie tool from the tool bar. Click the left mouse button where you want the center of the pie. 
Click the left mouse button where you want the pie slices starting angle. Without releasing the button, 
drag the mouse anticlockwise to the ending angle, while also moving away from the center till the pie 
slice has the desired radius.



How to draw a curve

Select the curve tool from the tool bar. Click the left mouse button where you want the first vertex of the 
curve. Without releasing the button, drag the mouse to the point where you want the second vertex, then
release the button. Click the left mouse button where you want the next vertex and release the button. 
Click and release the left mouse button where you want the next vertex, and the next, and so on. When 
you come to the last vertex, double click the left mouse button.

To draw a closed curve, double click on the first vertex, as the last vertex.

To create a corner vertex as opposed to a smooth vertex, hold down the shift key while creating the 
vertex.



How to draw text

Select the text tool from the tool bar. Click the left mouse button where you want to enter the text. Key in 
the text. To start another line, click the left mouse button where you want to enter the next line.

To edit existing text, select the text tool from the tool bar and click the left mouse button on the baseline 
of the text you would like to edit. Use left and right arrow keys to position cursor. Use backspace key to 
delete characters.

To use a different font, select Font from the Special menu. The font dialog only lists PostScript fonts. 
Fonts are listed by their PostScript names.

The text tool will only work if you have installed Adobe Type Manager (ATM) software. PageDraw 
requires ATM Version 2.01 or later. Only ATM fonts, i.e., PostScript Type 1 fonts are supported. 
TrueType and other font formats are not supported in this version of PageDraw. 

What is Adobe Type Manager?
Adobe Type Manager software enables other application software such as word processors and 
graphics programs to display high quality scaleable PostScript Type 1 fonts on the screen, as well as 
print them on laser and dot-matrix printers. ATM is more powerful than the TrueType functionality built in 
to MS-Windows because ATM is capable of applying arbitrary transforms (such as skewing) to fonts.

Where to get Adobe Type Manager?
If you have installed a word processor such as Word Perfect for Windows or Ami Pro on your machine, 
you may already have ATM. Visit your local software store, or contact Adobe Systems Inc. at (800)833-
6687 to obtain the latest version of Adobe Type Manager.



How to move objects

First, select the objects you would like to move. Click the left mouse button on any one of the selected 
objects. Without releasing the button, drag the mouse until the objects have been moved to the desired 
position; then release the button.

To undo move, select Undo from the Edit menu before unselecting the objects.



How to scale objects

First, select the objects you would like to scale. Select the scale tool from the tool bar. Click the left 
mouse button on the origin, i.e., the point about which you would like to scale the objects. Move the 
mouse away from the origin. Click anywhere and without releasing the mouse button, drag the mouse 
until the objects have been scaled to the desired size.

To scale objects uniformly in horizontal and vertical directions, hold down the shift key while dragging the
mouse.

To undo scale, select Undo from the Edit menu before unselecting the objects.



How to rotate objects

First, select the objects you would like to rotate. Select the rotate tool from the tool bar. Click the left 
mouse button on the origin, i.e., the point about which you would like to rotate the objects. Move the 
mouse away from the origin. Click anywhere and without releasing the button, drag the mouse until the 
objects have been rotated through the desired angle.

To rotate the objects in steps of 15 degrees, hold down the shift key while dragging the mouse.

To undo rotate, select Undo from the Edit menu before unselecting the objects.



How to skew objects

First, select the objects you would like to skew. Select the skew tool from the tool bar. Click the left 
mouse button on the origin, i.e., the point about which you would like to skew the objects. Move the 
mouse away from the origin. Click anywhere and without releasing the button, drag the mouse until the 
objects have been skewed to the desired shape.

To constrain the skewing to either horizontal or vertical direction, hold down the shift key while dragging 
the mouse.

To undo skew, select Undo from the Edit menu before unselecting the objects.



How to reflect objects

First, select the objects you would like to reflect. Select the reflect tool from the tool bar. Click the left 
mouse button on the origin, i.e., the point about which you would like to reflect the objects. Move the 
mouse away from the origin. Click anywhere and without releasing the button, drag the mouse until the 
objects have been reflected about the desired line.

To undo reflect, select Undo from the Edit menu before unselecting the objects.



How to select objects

Select the selection tool from the tool bar. Click the left mouse button in an empty area near the objects 
you would like to select. Without releasing the button, drag the mouse until the selection marquee 
encloses the objects you would like to select. An object need not be enclosed entirely within the 
selection marquee in order to get selected. If a small portion of the object falls within the selection 
marquee, it will be included in the selection.

You can also toggle the selection status of an object, i.e., remove an object from the selection if it is 
already included in the selection, or add it to the selection if it is not already included. To toggle the 
selection status of an object, hold down the shift key while following the same steps as when you select 
an object.

To unselect all objects, click in an empty area on the page.



How to import your drawing into a word processor

Drawings created using PageDraw can be included in documents created using LaTeX, Microsoft Word, 
Ami Pro, or other word processors. To import your drawing into a word processor, save your drawing in 
EPS format. Use the EPS inclusion capability of your word processor to include the drawing in a 
document. Since EPS files created by this version of PageDraw do not contain a preview, the drawing 
will only appear as a rectangle in the word processor. However, when the document is printed on a 
PostScript printer, the drawing will appear correctly in its place.

To save your drawing in EPS format, choose Save As from the File menu. Then change the Save File as
Type to EPS.



How to change orientation to portrait or landscape mode

You can change the orientation of the page at any time to portrait or landscape mode and continue 
drawing. Select Orientation from View menu and choose the orientation you want to change to. Since 
orientation is only a view mode, you can switch from one orientation to another and back as many times 
as you want.



How to change fill style

To change the fill style of objects, first select    the objects which you want to change. Then choose the 
shade (black, white or gray), or pattern you want from the Fill menu. The fill style you choose will remain 
in effect for the objects you draw later, until you change the fill style again.



How to change line style

To change the line style of objects, first select    the objects which you want to change. Then choose the 
dash style or line width you want from Line menu. Note that dashed lines can only be 1 point wide. The 
line style you choose will remain in effect for the objects you draw later, until you change the line style 
again.



How to draw arrow heads at ends of lines

To draw arrow heads at ends of lines, first select the lines you are interested in. Then choose any of the 
last four items in the Line menu, depending on whether you want no arrow heads, arrow head on the 
first end, arrow head on the second end, or arrow heads on both ends. Three different arrow styles are 
available--Small, Big and Fancy. To change the arrow style, select the lines you are interested in. Then 
choose the style you want from the Arrows menu. To access the Arrows menu, click on Style menu and 
then click on Arrows.



PageDraw is FREE software

No charges are due to the author for using PageDraw. Permission is also granted to distribute 
unmodified copies of PageDraw, without any charges being due to the author.

PageDraw is Copyright (c) 1993-95 Rajeev Karunakaran

PageDraw is distributed with NO WARRANTY of any kind. The author or distributors of this software do 
not accept responsibility for any damages arising from the use of this software.

How to send in your comments

You are invited to send me your questions, comments, any bugs you have found, or suggestions for the 
next version of PageDraw. New features I choose to implement depends on the number of requests for 
a particular feature that I receive from users.

Future development of PageDraw will depend on the response I get. If no one tells me PageDraw has 
been useful to them I will probably drop further development of PageDraw.

If you have access to the Internet, please send me e-mail at the address:

rajeev@netcom.com

I can also be contacted using the following address:

Rajeev Karunakaran
P.O. Box 51021
Palo Alto, CA 94303
U.S.A.




